viernes, 23 de octubre de 2009

No se ven las Imágenes del ToolBar en Crystal Reports

Un error  que aparecio al  usar Crystal Reports donde al momento de subir a producción la aplicación nos dimos cuenta que visor no mostraba las imágenes de los botones del toolbar por lo que opte por la primera solución, pero no muy convencido con lo que se hizo busque entre las librerías de Crystal Report y me encontré con la segunda solución la cual me parece lo mas estético y hasta cómodo para evitar futuros problemas. Aquí les dejo Ambas soluciones:
Solución 1:
Copiar la carpeta aspnet_client del IIS (C:\inetpub\wwwroot\aspnet_client) de mi maquina para colocarla en el IIS del Servidor o si no dentro de la aplicación, en ambas circunstancia nos funciono.
Solución 2:
La otra solución es copiar las imágenes del Crystal Reports (C:\Windows\Microsoft.NET\Framework\v2.0.50727\ASP.NETClientFiles\CrystalReportWebFormViewer4\images\toolbar) y colocarla en una carpeta en mi aplicación y escribir una línea de código donde le paso el nombre de la carpeta donde se encuentra las imágenes.
   1: ReportViewer1.ToolbarImagesFoldeUrl="MisImagenesReportes/toolbar/"
Solucion 2.1
Esta solucion es partiendo de que copiamos las imagenes de Crystal Reports a nuestra aplicacion y que no queremos lanzar codigo pues podemos decirle al visor mediante el HTML donde buscar las imagenes.
   1: <CR:CrystalReportViewer ID="CrystalReportViewer1" runat="server" 
   2: AutoDataBind="true" HasCrystalLogo="False" EnableDatabaseLogonPrompt="False" 
   3: EnableParameterPrompt="False" GroupTreeImagesFolderUrl="/MisImagenesReportes/tree/" 
   4: ToolbarImagesFolderUrl="/MisImagenesReportes/toolbar/" />

Espero que este pequeño aporte les sea de mucha utilidad.

saludos.
JC

No hay comentarios:

Publicar un comentario en la entrada